ビューを使うと、[[Basesの紹介|ベース]]内の情報をさまざまな方法で整理できます。ベースには複数のビューを含めることができ、各ビューにはファイルの表示、並べ替え、フィルタリングのための独自の設定を持たせることができます。
例えば、「Books」というベースを作成し、「Reading list」と「Recently finished」という別々のビューを持たせることができます。
## ツールバー
ベースの上部には、ビューとその結果を操作するためのツールバーがあります。
- ![[lucide-table.svg#icon]] **ビューメニュー** — ビューの作成、編集、切り替え。
- **結果** — ファイルの制限、コピー、エクスポート。
- ![[lucide-arrow-up-down.svg#icon]] **並べ替え** — ファイルの並べ替え。
- ![[lucide-stretch-horizontal.svg#icon]] **グループ** — ファイルのグループ化とグループの順序・表示の管理。
- ![[lucide-list-filter.svg#icon]] **フィルター** — ファイルのフィルタリング。
- ![[lucide-list.svg#icon]] **プロパティ** — 表示するプロパティの選択と[[数式]]の作成。
- ![[lucide-search.svg#icon]] **検索** — 表示されたプロパティを使用してアイテムを検索。
- ![[lucide-plus.svg#icon]] **新規** — 現在のビューに新しいファイルを作成。
スマートフォンでは、**結果**、**並べ替え**、![[lucide-stretch-horizontal.svg#icon]] **グループ**、**プロパティ** は ![[lucide-sliders-horizontal.svg#icon]] **表示** メニュー内にあります。
## ビューの追加と切り替え
ベースにビューを追加するには2つの方法があります:
- 左上のビュー名をクリックし、![[lucide-plus.svg#icon]] **ビューを追加** を選択する。
- [[コマンドパレット]]を使用して **Bases: Add view** を選択する。
ビューリストの最初のビューがデフォルトでロードされます。ビューのアイコンをドラッグして順序を変更できます。
## ビュー設定
各ビューには独自の設定オプションがあります。ビュー設定を編集するには:
1. 左上のビュー名をクリックする。
2. 設定したいビューの横にある右矢印をクリックする。
または、ベースのツールバーでビュー名を *右クリック* すると、ビュー設定にすばやくアクセスできます。
## レイアウト
ビューは、![[lucide-table.svg#icon]] **テーブル**、![[lucide-list.svg#icon]] **リスト**、![[lucide-layout-grid.svg#icon]] **カード**、![[lucide-kanban-square.svg#icon]] **カンバン**、![[lucide-map.svg#icon]] **マップ** など、さまざまなレイアウトで表示できます。追加のレイアウトは[[コミュニティプラグイン]]で追加可能です。
| レイアウト | 説明 | アプリバージョン |
| --------------------- | --------------------------------------------------------------------------------------------- | ---------------- |
| [[テーブルビュー\|テーブル]] | ファイルをテーブルの行として表示します。列はノートの[[プロパティ]]から生成されます。 | 1.9 |
| [[カードビュー\|カード]] | ファイルをカードのグリッドとして表示します。画像を使ったギャラリーのようなビューを作成できます。 | 1.9 |
| [[リストビュー\|リスト]] | ファイルを箇条書きまたは番号付きマーカーの[[基本的な書式構文#リスト\|リスト]]として表示します。 | 1.10 |
| [[カンバンビュー\|カンバン]] | ファイルをグループ化されたプロパティに基づいて列に整理されたカードとして表示します。 | 1.14 |
| [[マップビュー\|マップ]] | ファイルをインタラクティブな地図上のピンとして表示します。Mapsプラグインが必要です。 | 1.10 |
## フィルター
ベースの上部にある ![[lucide-list-filter.svg#icon]] **フィルター** メニューを開いてフィルターを追加します。
フィルターのないベースは、保管庫内のすべてのファイルを表示します。フィルターは結果を絞り込み、特定の条件を満たすファイルのみを表示します。例えば、特定の[[タグ|タグ]]を持つファイルや特定のフォルダ内のファイルのみを表示するためにフィルターを使用できます。多くのフィルタータイプが利用可能です。
フィルターは、![[lucide-list-filter.svg#icon]] **フィルター** メニューの2つのセクションから選択して、ベース内のすべてのビューに適用することも、単一のビューにのみ適用することもできます。
- **すべてのビュー** はベース内のすべてのビューにフィルターを適用します。
- **このビュー** はアクティブなビューにフィルターを適用します。
#### フィルターのコンポーネント
フィルターには3つのコンポーネントがあります:
1. **プロパティ** — 保管庫内の[[プロパティ]]([[Bases構文#ファイルプロパティ|ファイルプロパティ]]を含む)を選択できます。
2. **演算子** — 条件の比較方法を選択できます。利用可能な演算子のリストはプロパティタイプ(テキスト、日付、数値など)によって異なります。
3. **値** — 比較する値を選択できます。値には数式や[[関数]]を含めることができます。
#### 結合条件
- **次のすべてが真** は `and` 文です — フィルターグループ内の *すべての* 条件が満たされた場合にのみ結果が表示されます。
- **次のいずれかが真** は `or` 文です — フィルターグループ内の *いずれかの* 条件が満たされた場合に結果が表示されます。
- **次のいずれも真ではない** は `not` 文です — フィルターグループ内の *いずれかの* 条件が満たされた場合、結果は表示されません。
#### フィルターグループ
フィルターグループを使うと、結合条件の組み合わせを作成して、より複雑なロジックを構築できます。
#### 詳細フィルターエディタ
コードボタン ![[lucide-code-xml.svg#icon]] をクリックして **詳細フィルター** エディタを使用します。フィルターの生の[[Bases構文|構文]]が表示され、ポイント&クリックインターフェースでは表示できない、より複雑な[[関数]]を使用できます。
## 結果の並べ替えとグループ化
![[lucide-arrow-up-down.svg#icon]] **並べ替え** メニューで結果を配置し、![[lucide-stretch-horizontal.svg#icon]] **グループ** メニューで類似のアイテムをセクションに整理します。
1つ以上のプロパティで結果を昇順または降順に配置できます。これにより、名前、最終編集日時、またはその他のプロパティ(数式を含む)でノートを一覧にすることが簡単になります。
各ビューには複数の並べ替えを設定できますが、グループ化は1つのプロパティによるもののみ可能です。
### 並べ替えの追加
1. ビュー上部の ![[lucide-arrow-up-down.svg#icon]] **並べ替え** メニューを開く。
2. **並べ替えを追加** を選択し、並べ替えたいプロパティを選択する。
3. 複数の並べ替えがある場合、![[lucide-grip-vertical.svg#icon]] グリップハンドルを使って上下にドラッグし、優先順位を変更する。
結果の順序のオプションはプロパティタイプによって異なります:
- **テキスト**: *アルファベット順*(A→Z)または *逆アルファベット順*(Z→A)で並べ替え。
- **数値**: *小さい順*(0→1)または *大きい順*(1→0)で並べ替え。
- **日付と時刻**: *古い順* または *新しい順* で並べ替え。
### 並べ替えの削除
1. ビュー上部の ![[lucide-arrow-up-down.svg#icon]] **並べ替え** メニューを開く。
2. 削除したい並べ替えの横にある ![[lucide-trash-2.svg#icon]] ゴミ箱ボタンを選択する。
### 結果のグループ化
1. ビュー上部の ![[lucide-stretch-horizontal.svg#icon]] **グループ** メニューを開く。スマートフォンでは **表示 → グループ** を開く。
2. **グループ化** でプロパティを選択する。
3. 自動並べ替え順序を選択するか、**手動** を選択してグループを自分で並べ替える。
結果のグループ化を停止するには、グループ化プロパティの横にある ![[lucide-trash-2.svg#icon]] ゴミ箱ボタンを選択します。
### グループの並べ替え、非表示、追加
![[lucide-stretch-horizontal.svg#icon]] **グループ** メニューで、並べ替え順序メニューから **手動** を選択すると、表示するグループとその順序を管理できます。
- グループにチェックを入れると表示され、チェックを外すと非表示になります。**すべて表示** または **すべて非表示** を選択すると、すべてのグループの表示を一括で変更できます。
- グループの横にある ![[lucide-grip-vertical.svg#icon]] グリップハンドルをドラッグして位置を変更します。
- **グループを追加** を選択して値を入力すると、新しい空のグループが表示されます。これはノートの作成や既存のノートの変更は行いません。
自動グループ順序を復元してすべてのグループを表示するには、**手動** の代わりに自動並べ替え順序を選択します。
### グループの折りたたみ
[[テーブルビュー|テーブル]]、[[カードビュー|カード]]、[[リストビュー|リスト]]レイアウトでは、グループの見出しを選択してそのグループを折りたたんだり展開したりできます。グループを折りたたむと、プロパティを変更せずにアイテムを一時的に非表示にします。
## 結果の制限、コピー、エクスポート
### 結果の制限
*結果* メニューにはビュー内の結果数が表示されます。結果ボタンをクリックして結果数を制限し、追加のアクションにアクセスできます。
### クリップボードにコピー
このアクションはビューをクリップボードにコピーします。クリップボードにコピーした後、Markdownファイルや、Google Sheets、Excel、Numbersなどのスプレッドシートを含む他のドキュメントアプリに貼り付けることができます。
### CSVエクスポート
このアクションは現在のビューのCSVを保存します。
## ビューの埋め込み
`![[File.base]]` 構文を使って、ベースファイルを[[ファイルの埋め込み|他の任意のファイル]]に埋め込むことができます。リスト内の最初のビューが使用されます。ビューメニューでビューをドラッグして順序を変更できます。
埋め込みのデフォルトビューを指定するには `![[File.base#View]]` を使用します。